[Gate-users] Optical processes error - No surface command enabled

David Larsson david.larsson at sth.kth.se
Fri Feb 27 17:51:38 CET 2015

Hi Vesna,

thanks for your advice. I've now tried to reinstall Geant4 (v.9.6.p03 using the built in CLHEP, i.e. GEANT4_USE_SYSTEM_CLHEP OFF) and Gate (v7.0). To be sure, I've redirected GATE to use CLHEP in case there is any issue with the built-in Geant4 version.

However, the same error message seem to occur when running the Optical_System.mac file.

Could it be some library files that for some reason are missing? Do you happen to know exactly how the Surfaces.xml-file is called? I think something might be incorrect there (at least with what I'm using).

Thanks again for your help,


Från: Vesna Cuplov <vesna.cuplov at gmail.com>
Skickat: den 27 februari 2015 16:49
Till: David Larsson
Kopia: gate-users at lists.opengatecollaboration.org
Ämne: Re: [Gate-users] Optical processes error - No surface command enabled

Hello David,

I just tried the example_OPTICAL from Gate v7.0 and it works. I tried both the Optical_System.mac (in that macro I had to change the EngineSeed from 123456789 to a smaller number like 210.... something was not behaving properly with the random seed generator on my installation, but that's not a major issue).
This test means that the macros from the example_OPTICAL are correct and that there is a problem with your install I think.

I see that you use Geant4 10.0.3 instead of the recommended Geant4 9.6.p03.
Also you do not need to use an external CLHEP version. Geant4 distributes a minimal version of CLHEP with the toolkit. So when configuring Geant4 before its compilation, you can leave the GEANT4_USE_SYSTEM_CLHEP OFF.  If you still wish to use an other CLHEP version for GATE, it is recommended to use

I think you should redo your install following the installation guide and the recommended software versions.

Hope this helps,

On Fri, Feb 27, 2015 at 8:34 AM, David Larsson <david.larsson at sth.kth.se<mailto:david.larsson at sth.kth.se>> wrote:

Dear Gate-users,

I am asking a question related to an issue I raised in a previous question/conversation to the mail-list (see e.g. http://article.gmane.org/gmane.comp.science.opengate.user/4549/match=david+larsson)

I want to simulate optical photon processes and have, after having issues with a created macro, gone back to the provided examples of Gate v7.0 (./examples/example_OPTICAL), . However, when trying to run the provided macros my batch run is interrupted with the error below.

Apparently, even though I've added optical processes they seem not to be initialized. Similarly, Gate does not seem to recognize surfaces as a valid feature of my geometries. This even though I run everything from the example folder with the Surfaces.xml and Materials.xml in the same directory.

I have succesfully re-compiled Gate with the optical processes set to 'ON' before attempting the simulations. I am running everything with the following versions:

     Your current Root version is 5.34/22

     Your current Geant4 version is 10.0.3

     Your current CLHEP version is

    Gate v7.0

Does anyone know what the problem might be and why I cannot succesfully simulate optical processes? Anyone having encountered something similar?

Any advice would be very helpful.


David Larsson

Error message:

***** COMMAND NOT FOUND </gate/crystal/surfaces/name Detection1> *****

***** Batch is interrupted!! *****

List of Enabled processes:

   ===  Process: OpticalMie  ===
Particle: opticalphoton

   ===  Process: OpticalBoundary  ===
Particle: opticalphoton

   ===  Process: OpticalAbsorption  ===
Particle: opticalphoton

   ===  Process: OpticalWLS  ===
Particle: opticalphoton

   ===  Process: OpticalRayleigh  ===
Particle: opticalphoton

List of initialized processes:

[Core-0] Initialization of geometry
[Core-0] Initialization of physics
[Physic-0] WARNING: manual physic lists are being deprecated.
Please, use physic list builder mechanism instead. Related documentation can be found at:
[Core-0] Initialization of actors
***** COMMAND NOT FOUND </gate/digitizer/Singles/readout/setDepth 1> *****

***** Batch is interrupted!! *****
Pulse-processor type name 'opticaladder' was not recognised --> insertion request must be ignored!
Session terminated.

-------- EEEE ------- G4Exception-START -------- EEEE -------
*** G4Exception : UI0001
      issued by : G4UIterminal::SignalHandler()
KeyboardInterrput with Ctrl-C
*** Fatal Exception *** core dump ***
-------- EEEE -------- G4Exception-END --------- EEEE -------

*** G4Exception: Aborting execution ***
Aborted (core dumped)


Gate-users mailing list
Gate-users at lists.opengatecollaboration.org<mailto:Gate-users at lists.opengatecollaboration.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/mailman/private/gate-users/attachments/20150227/7cd6083f/attachment-0001.html>

More information about the Gate-users mailing list