[Gate-users] ecat

Simon Stute gate.stute at gmail.com
Tue Feb 26 10:36:31 CET 2013


I don't know how to use the program from Dr. Schmidtlein, contact him if
you have a problem.
The -L option used to give the path to appropriate libraries must be given
to the compiler, not to the make program ... so add it inside your makefile
(in CPPFLAGS and/or LDFLAGS). This should work.
Anyway, I think that the socket library should be useless on linux (not
sure), so just try to delete the -lsocket option and see if it works too.
I take the liberty of forwarding this email to the mailing list as if any
other user encounters the same problem, he should find the solution.


On Tue, Feb 26, 2013 at 9:47 AM, Saeed Heidary <saeedheidary79 at gmail.com>wrote:

> Dear Simon
> You are right I was not so patient to search, although I saw the URL
> before, but I did not scrutinize it, please accept my apology. But the
> problem still exists.
> the procedure I am doing ...
> before compiling the GATE, I have tried to compile ecat Makefile and utils
> Makefile ,
> If you take a quick look at INSTALL file in ecat, I have tried to do the
> same way
> the error '-lsocket' happened during installin the utils Makefile, even
> though I use "make -L /usr/lib/happycoders" , the problem was not solved.
> so I decided to ignore the utils and continue, after doing ccmake and
> configuring the paths (ECAT Home etc.) every things compiled
> but I still have the linking problem !
> Any way, just I gonna have sinogram or projection in PET, the standard
> output of cylindricalPET is root so I used the Bin.Gate.C by Dr.shmidelton
> , but I could not
> applied it to my desire, is there any solution ?
> Many thanks in advance
> Saeed
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/mailman/private/gate-users/attachments/20130226/bf1dec75/attachment-0001.html>

More information about the Gate-users mailing list