[Gate-users] GATE v8.2 installation error

David Boersma david.boersma at acmit.at
Sun Feb 17 20:04:22 CET 2019

Hi Ezzat,

Could you check your shell environment? In particular: does Gate get linked against the same geant4 install as the one you used to compile Gate v8.2?

One way to check (on linux, this this won't work on macos):

ldd $(which Gate)

The "G4" libraries should be the ones from 10.05. One way to get wrong linking is to have an old "source /my/favorite/geant4/install/bin/geant4.sh" in your .bashrc (a bad habit, in my opinion, but widespread).

Von: Gate-users <gate-users-bounces at lists.opengatecollaboration.org> im Auftrag von Ezzat Elmoujarkach <ezzat.elmo at gmail.com>
Gesendet: Sonntag, 17. Februar 2019 13:27:06
An: gate-users at lists.opengatecollaboration.org
Betreff: [Gate-users] GATE v8.2 installation error

Dear Gaters,

I tried installing the new version 8.2 , everything went smoothly. When I tried to run any simulation (even just Gate) I get this error:

>> gate at GATE:~$ Gate
>> Gate: symbol lookup error: Gate: undefined symbol: aPrimaryVertexAllocator

I don't know how to troubleshoot this error so any help will be appreciated,
The operating system is Ubuntu 14.04, Geant4-10.05, ROOT 5.34

Thanks for the help.
Best Regards,

More information about the Gate-users mailing list