[Gate-users] Compiling error

tomato98 lee tomato98 at gmail.com
Tue Jul 1 05:05:07 CEST 2008


I think.. I had a similar error when I have installed gate on my laptop.
I'm not sure it was the same error message with yours..
But my answer could be help you..

Which version of Mac OS do you use?
Actually my laptop works in Mac OS X 10.5 Leopard.
And Leopard has some bugs in OpenGL.
So.. I solved that problem by adding some texts at GNUmakefile.

I hope it will be worked..
May the force be with you.

Hakjae Lee, KU MIPL

2008/7/1 Martin Janecek <mjanecek at lbl.gov>:
> Hello all,
> Does anybody know what causes the error below? Is there a parameter that is
> not correctly set? (All the errors seem to point to optical processes.)
> I have successfully installed CLHEP, GEANT 4.9.0, and ROOT 5.14. I
> believe I have set the paths correctly, but when I try to install GATE 3.1.2
> by running 'make', the compilation gives me the following error:
> make
> =>
> warning: this program uses gets(), which is unsafe.
> Using granular libraries ...
> Linking Gate ...
> powerpc-apple-darwin8-g++-4.0.1: unrecognized option '-rdynamic'
> /usr/bin/ld: Undefined symbols:
> G4OpRayleigh::G4OpRayleigh(G4String const&, G4ProcessType)
> G4OpAbsorption::G4OpAbsorption(G4String const&, G4ProcessType)
> G4Scintillation::G4Scintillation(G4String const&, G4ProcessType)
> G4OpBoundaryProcess::G4OpBoundaryProcess(G4String const&, G4ProcessType)
> collect2: ld returned 1 exit status
> make: *** [/Applications/g4work/bin/Darwin-g++/Gate] Error 1
> Thanks,
> Martin
> _______________________________________________
> Gate-users mailing list
> Gate-users at lists.healthgrid.org
> http://lists.healthgrid.org/mailman/listinfo/gate-users

More information about the Gate-users mailing list