[Gate-users] Problem with ROOT and ASCII output DATA

Davi Francois davifrancois at hotmail.com
Tue Jan 29 18:07:40 CET 2008

Hi gate users,
I have sucessfull compiled and installed gate 3.1.2 with Suse 10.1, but I think there is a problem with output data Gate.
 When I run for example the benchmarkSPECT, it gives me this message:
***** COMMAND NOT FOUND </gate/output/root/setSaveRndmFlag 1> *****
Or if I try run example benchmarkPET, it gives me this message:
***** COMMAND NOT FOUND </gate/output/ascii/setOutFileHitsFlag 0> *****
This messages are justified, because if I run Gate in any terminal and put ls gate/output, I don’t have the sub-directories root and ascii, only analysis and digi.
Then I ask: What is wrong with my configuration? Someone have an idea? 
I don't know where is the problem, because I think that all environment are ok, but I don't have sub-directories gate/output/ascii and gate/output/root.
What must I do to have the sub-directories root and ascii? My G4ANALYSIS_USE_FILE and G4ANALYSIS_USE_ROOT that enable ASCII and ROOT output files are set to =1, however I think that they don’t work.
My environment is:
export ROOTSYS=/geant4/root_v5.14.00h/root
export PATH=$ROOTSYS/bin:$PATH
export G4WORKDIR=/g4work
export GATEHOME=/geant4/gate_v3.1.2/gate_v3.1.2
export G4VERSION=9.0
export LMF_HOME=/geant4/lmf_v3.0/lmf_v3.0
export ECAT7_HOME=/geant4/ECAT
source /geant4/geant4.9.0.p01/env.sh
export LD_LIBRARY_PATH=$ROOTSYS/lib:/usr/local/lib:/geant4/geant4.9.0.p01/lib:$LD_LIBRARY_PATH

When I run ./env_gate.sh is returned:
The current value of G4INSTALL is: /geant4/geant4.9.0.p01
The current value of G4VERSION is: 9.0
Launching Geant4 configuration script /geant4/geant4.9.0.p01/env.sh
On this machine the G4SYSTEM=Linux-g++
On this machine the G4INSTALL=/geant4/geant4.9.0.p01
On this machine the G4INCLUDE=/geant4/geant4.9.0.p01/include/
On this machine the G4LIB=/geant4/geant4.9.0.p01/lib
On this machine the G4LEVELGAMMADATA=/geant4/geant4.9.0.p01/data/PhotonEvaporation2.0
On this machine the G4RADIOACTIVEDATA=/geant4/geant4.9.0.p01/data/RadioactiveDecay3.2
On this machine the G4LEDATA=/geant4/geant4.9.0.p01/data/G4EMLOW4.3
On this machine the G4NEUTRONHPDATA=/geant4/geant4.9.0.p01/data/G4NDL3.11
On this machine the CLHEP_BASE_DIR=/usr/local
On this machine the CLHEP_INCLUDE_DIR=/usr/local/include
On this machine the CLHEP_LIB_DIR=/usr/local/lib
On this machine the CLHEP_LIB=CLHEP
On this machine the G4ANALYSIS_USE=1
On this machine the G4VIS_BUILD_DAWN_DRIVER=1
On this machine the G4VIS_BUILD_OPENGLX_DRIVER=1
On this machine the G4VIS_BUILD_VRML_DRIVER=1
On this machine the G4VIS_USE_DAWN=1
On this machine the G4VIS_USE_OPENGLX=1
On this machine the G4VIS_USE_RAYTRACERX=1
On this machine the G4VIS_USE_VRML=1
On this machine the XMFLAGS=
On this machine the XMLIBS=
On this machine the XMFLAGS=
On this machine the XAWFLAGS=
On this machine the XAWLIBS=
On this machine the G4LIB_BUILD_STATIC=1
On this machine the G4LIB_USE_GRANULAR=1
On this machine the G4UI_USE_TCSH=1
Configuring GATE options
G4WORKDIR set to /g4work
G4TMP set to /g4work/tmp
G4BIN set to /g4work/bin
Data analysis and output features enabled
Ascii data output enabled
Transport and generation of optical photons is enabled
Checking your LD_LIBRARY_PATH variable...
 ==> OK: /geant4/root_v5.14.00h/root/lib is already in your LD_LIBRARY_PATH
Use of ROOT enabled
ROOT real-time plotter disabled
Checking your LD_LIBRARY_PATH variable...
 ==> OK: /geant4/lmf_v3.0/lmf_v3.0/lib is already in your LD_LIBRARY_PATH
LMF data output enabled
ECAT7 data output enabled
GATEHOME is set to /geant4/gate_v3.1.2/gate_v3.1.2
Checking your path variable...
 ==> OK: /geant4/gate_v3.1.2/gate_v3.1.2/bin/Linux-g++ is already in your path variable
G4VERSION8 is not set: GATE is not compatible with the geant4 version 8.1.p02
G4VERSION9 is set: GATE is compatible with the geant4 version  9.0

Davi François

Encontre o que você procura com mais eficiência! Instale já a Barra de Ferramentas com Windows Desktop Search! É GRÁTIS! 
Veja mapas e encontre as melhores rotas para fugir do trânsito com o Live Search Maps!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/mailman/private/gate-users/attachments/20080129/56b74a85/attachment.htm>

More information about the Gate-users mailing list