[Gate-users] Importing DICOM CT data

Rukiah katoshka_7880 at yahoo.com
Wed Dec 23 05:10:35 CET 2020

Hi,This response might be late. And I am not sure if you found the solution.I just want to share my experience on creating voxelized phantom from CT image, using GATE 7.2 back then. I experienced the same error and thought that was nothing to do with the image format since GATE 7.2 accept the uint or int image. I was using Analyze or Interfile format during that time since 7.2 version was not able to accept Dicom.
The error occurred because the CT image and the HU calibration txt does not have the same min or max HU. In your case, GATE detected the HU of -1000, however, in HU calibration txt, the min HU started at higher than -1000. Therefore, GATE was not able to define and calibrate the HU less than -1000.Whether you can rescale back the CT image according to the HU calibration txt or vice versa, the problem will be solved.
Good luck.


    On Friday, December 18, 2020, 06:39:01 AM GMT+8, Bryan McIntosh <mcintoshster at gmail.com> wrote:  
 Hi everyone,
I am working on a side project to do some HDR brachytherapy dosimetry in GATE 8.2, and am having a very difficult time creating a voxelized phantom based on the DICOM CT data of our prostate phantom. However, as my simulation starts I get the following error as the voxelized phantom is turned into an image volume:
"GateVImageVolume.cc (l.742):  I find R=-1000 in the image, while range stop at -1001"

The only reference I could find in the mailing list archives to this was back in 2016, before GATE had DICOM import capability. The same issue happens if I try to import the volume split across multiple files (the default from our planning CT system) or as a single file (using AMIDE to export the multi-file data). I'd rather not change the data to an Interfile format, since GATE won't import Interfile data unless it's an unsigned INT; that would make it pretty difficult to have CT data for the air-equivalent part of the phantom that represents the colon!
So, has anyone found a way to work around this? Is this fixed in GATE 9.0 and I just need to install the new version, or is there some other fix i need to go through? I'll post the beginning of my macro and system configuration below.

Thanks for your time,
-Bryan McIntosh
My configuration:
Linux Mint 19.3
GATE 8.2, GEANT4 10.5.p01, root 6.14, ITK 5.1.2Ryzen 7 3700X, 16 GB RAM, Gigabyte X470
Phantom-defining macro content
/gate/geometry/setMaterialDatabase GateMaterials.db

# World
/gate/world/geometry/setXLength 3 m
/gate/world/geometry/setYLength 3 m
/gate/world/geometry/setZLength 3 m
/gate/world/setMaterial Air

#Generate Hounsfield unit table (commented out after 1st run)
#/gate/HounsfieldMaterialGenerator/SetMaterialTable                  data/Schneider2000MaterialsTable.txt
#/gate/HounsfieldMaterialGenerator/SetDensityTable                   data/Schneider2000DensitiesTable.txt
#/gate/HounsfieldMaterialGenerator/SetDensityTolerance               0.1 g/cm3
#/gate/HounsfieldMaterialGenerator/SetOutputMaterialDatabaseFilename data/patient-HUmaterials.db
#/gate/HounsfieldMaterialGenerator/SetOutputHUMaterialFilename       data/patient-HU2mat.txt

# Voxelized prostate phantom
/gate/world/daughters/name prostate

/gate/world/daughters/insert ImageNestedParametrisedVolume
/gate/prostate/geometry/setImage                data/CT.T111112.1.dcm
/gate/geometry/setMaterialDatabase     data/patient-HUmaterials.db
/gate/prostate/geometry/setRangeToMaterialFile  data/patient-HU2mat.dat

Gate-users mailing list
Gate-users at lists.opengatecollaboration.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/pipermail/gate-users/attachments/20201223/b5cb176f/attachment-0001.html>

More information about the Gate-users mailing list