[Gate-users] Problem with Install Vrmlview

Boersma David david.boersma at medaustron.at
Mon Apr 16 18:20:11 CEST 2018

Hi Mery,

Please keep the conversation on the mailing list. The topic could possibly be useful to other users. And maybe there is someone on the list who can answer these questions better/faster than I can.

Can you describe in a bit more detail what is not working properly when you add a phantom and view your setup in Gate with OGLSX?

About “error while loading shared libraries”:

·         Check where exactly the file libFreeWRL.so.2 got installed, let’s say it turns out to be /some/long/path/lib/libFreeWRL.so.2

·         Run this command (with the proper path, of course): export LD_LIBRARY_PATH=/some/long/path/lib:$LD_LIBRARY_PATH

·         Try running freewrl, in the same shell (terminal) where you did the “export” command.

o   If it fails with the same error: maybe you made a typo? Maybe something else is wrong?

o   If it works: congratulations! Note that right now it only works in this shell. If you logout and log back in, or you open a new terminal window, then you first need to run that “export” command again. If you think you will use this program a lot then you can add that export command to your shell configuration so that it gets loaded automatically when you login. Or you add an alias to your .bashrc, something like “alias fw=’export ): export LD_LIBRARY_PATH=/some/long/path/lib:$LD_LIBRARY_PATH && freewrl’”

Good luck,

From: Mery MB [mailto:mery.mb.mph at gmail.com]
Sent: Monday, April 16, 2018 5:59 PM
To: Boersma David <david.boersma at medaustron.at>
Subject: Re: [Gate-users] Problem with Install Vrmlview

Hi Dear David
Thanks for your email.
Actually I need a proper viewer to view my geometry.
I simulate a linac with rotated Gantry and source ... The only viewer which is  show my geometry is OGLSX But when I add the phantom it do not work properly.....
I tried to install freewrl but it not work after installation  and get this error:
freewrl: error while loading shared libraries: libFreeWRL.so.2: cannot open shared object file: No such file or directory
I wonder if you can help me in this issue too?

On Mon, Apr 16, 2018 at 5:20 PM Boersma David <david.boersma at medaustron.at<mailto:david.boersma at medaustron.at>> wrote:
Hi Mery,

I see that this VRMLview tool is advertised on our wiki:

There are some problems with that documentation (for instance that most users are using “bash” or “zsh”, not “a C-schell”). I tried downloading the tarball from the www.sim.no<https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sim.no&data=02%7C01%7Cdavid.boersma%40medaustron.at%7C9c0bf1953e464a293dba08d5a3b2f5c9%7Cadb749e06dfd4f6fbea8cd9f8e0c9b89%7C0%7C1%7C636594911381175158&sdata=0H5YgEft4m2gQXwEu%2BnSzVJvns36HhAypcVoQT7tcME%3D&reserved=0> link, but this gives me a time out, maybe they are out of business? Whoever created this wiki page is cordially invited to update it. ☺

So maybe you can use a different VRML viewer? Google told me that “view3dscene” is able to visualize VRML files, it’s a standard package that is available for Ubuntu through the usual software management tools (apt-get, synaptic).


From: Gate-users [mailto:gate-users-bounces at lists.opengatecollaboration.org<mailto:gate-users-bounces at lists.opengatecollaboration.org>] On Behalf Of Mery MB
Sent: Monday, April 16, 2018 12:59 PM
To: gate-users at lists.opengatecollaboration.org<mailto:gate-users at lists.opengatecollaboration.org>
Subject: [Gate-users] Problem with Install Vrmlview

Dear Gater
I want to install Vrmlview on my linux (ubuntu 16.04LTS). But I get the following error:

mery at ubuntu:~/Gate/Install/Vrmlviewer$ ./vrmlview
bash: ./vrmlview: No such file or directory
At first I extract the vrmlview.tar.gz in a new folder in install folder
I have 3 files in my folder: LICENSE.TXT README and vrmlview
Then in terminal I write ./vrmlview But I get the above error.
I wonder if someone encounter such problem and can help me?

Please notice our E-Mail Disclaimer http://www.medaustron.at/email-disclaimer/<https://emea01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.medaustron.at%2Femail-disclaimer%2F&data=02%7C01%7Cdavid.boersma%40medaustron.at%7C9c0bf1953e464a293dba08d5a3b2f5c9%7Cadb749e06dfd4f6fbea8cd9f8e0c9b89%7C0%7C1%7C636594911381175158&sdata=wZGLEj4jNaffCzm5iEUZie3zOHa23yywlWOplvVqCs8%3D&reserved=0>

Please notice our E-Mail Disclaimer http://www.medaustron.at/email-disclaimer/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/pipermail/gate-users/attachments/20180416/77025587/attachment-0001.html>

More information about the Gate-users mailing list