[Gate-users] Parameterizing errors

Andreas Tefre Samnøy andreas.samnoy at gmail.com
Tue Oct 10 11:14:24 CEST 2017


I am running Gate 8.0 and cannot seem to get parameterized macros to work.
I have a working simulation and I have tried copy pasting in the examples
from the Gate User Guide, but I still cannot make it work.

In my working simulation I have added the following:
/gate/digitizer/Singles/insert thresholder
/gate/digitizer/Singles/thresholder/setThreshold {lld} keV

I Then run Gate using the following command:
$ Gate -a [lld,350]

But when I run the simulation I get the following error
[G4-cerr] Alias <lld> not found -- command ignored
[G4-cerr] ***** Illegal parameter (0)
</gate/digitizer/Singles/thresholder/setThreshold {lld} keV> *****
[Gate] Sorry, error in a macro command : abort.

I have also tried to run Gate and used the commands:
PreInit> /control/alias lls 350
PreInit> /control/listAlias
  lls : 350

But I still get the same error. Does anybody know what I am doing wrong?

The simulation works fine if I exchange the {lls} with 350 in the macro
file, so that it becomes:
/gate/digitizer/Singles/thresholder/setThreshold 350 keV

Best Regards
Andreas Tefre Samnøy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/pipermail/gate-users/attachments/20171010/288c499a/attachment.html>

More information about the Gate-users mailing list