[Gate-users] Issue enabling Surfaces/Optical Photons - COMMAND NOT FOUND - Gate v.7

David Larsson davlars at kth.se
Mon Feb 2 10:14:03 CET 2015

Hi Vesna,

thanks for your answer. Yes I did add 'OpticalBoundary', 'OpticalAbsorption', 'OpticalRayleigh' and 'OpticalMie' within my mac-script, however I still get the same error message (i.e. 'surfaces'-commands not found/available).

I have tried to run the same script on a previous Geant4-compilation (9.6) as well as earlier libraries of CLHEP ( and but still have the same issue. It seems like I have succesfully turned ON the GATE_USE_OPTICAL setting (since I can add optical physical processes without any problems) but still, the surface-options seems to still be lacking. Anyone having encountered the same or knows what I could try to resolve this?

Thanks for your help,


Från: Vesna Cuplov <vesna.cuplov at gmail.com>
Skickat: den 31 januari 2015 16:37
Till: David Larsson
Kopia: gate-users at lists.opengatecollaboration.org
Ämne: Re: [Gate-users] Issue enabling Surfaces/Optical Photons - COMMAND NOT FOUND - Gate v.7

Hello David,

Did you specify the following physics processes?

/gate/physics/addProcess OpticalAbsorption
/gate/physics/addProcess OpticalRayleigh
/gate/physics/addProcess OpticalBoundary <== needed for Surface processes
/gate/physics/addProcess OpticalMie

Hope this helps,

On Wed, Jan 28, 2015 at 6:59 PM, David Larsson <davlars at kth.se<mailto:davlars at kth.se>> wrote:
Dear Gate-users,

I'm just about to start working with optical photons in Gate and have gotten a test script for trying this feature. However, when running I get the error message below:

***** COMMAND NOT FOUND </gate/micropixels/surfaces/name glasslayer_micropixels> *****

I can manually within Gate see that "surfaces" is not an enabled feature of any created geometry. I've followed the User guide and made sure that GATE_USE_OPTICAL is set to "ON", recompiled and re-run the Gate-installation (make install). However, I still seem to get this issue.

I'm working with the following package versions:

    Root version is 5.34/22

    Geant4 version is 10.0.3

    CMake version

    CLHEP version is

    Gate version is 7.0

Does anyone know what I have to do to enable surface and optical photon options? Does anyone know how to proceed from the above?

Thanks in advance for your help.

Best regards,

David Larsson

Gate-users mailing list
Gate-users at lists.opengatecollaboration.org<mailto:Gate-users at lists.opengatecollaboration.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/mailman/private/gate-users/attachments/20150202/b0954026/attachment.html>

More information about the Gate-users mailing list