[gate-users] FC4 and GATE

Peter M. Bloomfield peter.bloomfield at camhpet.ca
Tue Aug 16 20:35:26 CEST 2005

Dear All,

I have just had an interesting experience with FC4, and this is really a heads 

I installed FC4 on a workstation (fresh install, no update) with the following
	OS - Fedora Core 4
	gcc - gcc (GCC) 4.0.1
	GATE : V2.2.0
	Geant4 : Geant4_7.0_p01
	CLHEP : 1.8.1
	Root : V4.04/02f (also used V5.02)
After compiling CLHEP and Geant, I compiled novice example N02 and executed it 
and all worked. I compiled root (disabling xrootd, known problme in root), 
and executed the benchmarks, which ran succesfully. I then compiled GATE, and 
executed the PET benchmark. I checked the output with the values on the web 
site and all appeared consistent.
At this point I ran a script for the HRRT, simulating the NEMA 2K scatter 
phantom. The script generates a root file which is processed to give me HRRT 
sinogram. This is where the problems appeared; the generated sinogram had 
both missing and mis-placed data. I had not seen this before with any 
previous install. I then re-installed version 1.2.0 of GATE, recompiled and 
re-executed the simulation, but the results were the same.

At this point, I went back and did a fresh install of FC3 on the same machine. 
I re-compiled all the code, performing the checks at each stage. Now running 
the simulation script I get back to a 'sensible' sinogram for the HRRT from 
the NEMA 2K scatter phantom.

I am not sure if I did something incorrect during the FC4 install, but I don't 
recall doing anything different. The only difference (and I am being a little 
loose with the term) is the compiler, under FC3 it is
	gcc (GCC) 3.4.4

Has anyone else had any similar experiences?



More information about the Gate-users mailing list