[Gate-users] G4sphere not available on nanometer scale

성원모 wsung at snu.ac.kr
Tue Nov 10 15:32:48 CET 2015

Dear John Apostolakis

Thanks for immediate and valuable comments!

However, unfortunately, both of your solutions does not resolve the problem.

1. I tried newest patch of Geant4 (e.g., v.4.10.01.p02) but same G4exception occurred.

2. I found how to change tolerance in G4 User Guide. Gate main or detector construction was modified so that it has G4GeometryManager just before defining any geometrical component of the setup.


G4GeometryManager::GetInstance()->SetWorldMaximumExtent(some value);

Tolerance change was observed using G4GeometryTolerance and tolerance was smaller than e-9 mm. However, same G4exception remains if I use setRmin.

I'm going to test same thing with Geant4 alone and report it in Geant4 Problem reporting system. I would appreciate any comments if you have any insights on this issue.


Wonmo Sung

보낸 사람: John Apostolakis <John.Apostolakis at cern.ch>
보낸 날짜: 2015년 11월 10일 화요일 오후 4:42
받는 사람: 성원모
참조: gate-users at lists.opengatecollaboration.org
제목: Re: [Gate-users] G4sphere not available on nanometer scale

Dear Wonmo Sung,

Could you confirm the version of Geant4 you are using?

I have two suggestions. The first is to try using the version of G4Sphere from the newest patch of Geant4. You can copy the source file into your installation, and, if needed only the header file and inline icc file from the include directory - and of course then the rebuild Geant4 libraries.

The second concerns the tolerance. The default value is 1.e-09 mm, which is not small enough for your geometry. You can see in the Users Guide how to adapt it to the size of your setup.

If your problem remains, I suggest to report it in the Geant4 Problem reporting system.

John Apostolakis

On 10 Nov 2015, at 08:15, 성원모 <wsung at snu.ac.kr<mailto:wsung at snu.ac.kr>> wrote:

Dear Gate users


I'm currently using Gate v7.1.

I tried to use setRmin for hollow sphere on nanometer scale.


/gate/sphere/geometry/setRmin 1 nm

/gate/sphere/geometry/setRmax 20 nm

However, I got G4Exception as below.

This error does not occur if I replace nm with mm OR if I use 0 nm for setRmin (=full sphere).

Could you provide any comments or help to solve this problem? I appreciate any help in advance.

    *** Dump for solid - sphere_solid ***
 Solid type: G4Sphere
    inner radius: 1e-06 mm
    outer radius: 2.000000000000001e-05 mm
    starting phi of segment  : 0 degrees
    delta phi of segment     : 360 degrees
    starting theta of segment: 0 degrees
    delta theta of segment   : 180 degrees

-------- WWWW ------- G4Exception-START -------- WWWW -------
*** G4Exception : GeomSolids1002
      issued by : G4Sphere::DistanceToOut(p,v,..)
Logic error: snxt = kInfinity  ???

p.x() = 5.106433541911882e-07 mm
p.y() = -7.11253374326104e-07 mm
p.z() = 9.224550730873363e-08 mm

Rp = 8.80424460864498e-07 mm


v.x() = 0.9926097739516453
v.y() = -0.02063914065141685
v.z() = 0.1195820326338147

Proposed distance :

snxt = 9e+99 mm

*** This is just a warning message. ***
-------- WWWW -------- G4Exception-END --------- WWWW -------


Wonmo Sung

Gate-users mailing list
Gate-users at lists.opengatecollaboration.org<mailto:Gate-users at lists.opengatecollaboration.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengatecollaboration.org/mailman/private/gate-users/attachments/20151110/ab189122/attachment-0001.html>

More information about the Gate-users mailing list